TLS 1.1 or older: Cannot establish secure connection

Support Center > Troubleshooting Connection Issues

Published 02/13/2021 at 6:29am UTC

Page viewed 1936 times

Symptom

If you are trying to access a SecureVideo.com page and getting a page loading error that references not being able to make a secure connection (example below using Internet Explorer 8 on Windows XP): 

Internet Explorer cannot display the webpage

Possible Causes

Your device may be running an older browser, using older encryption protocols that are no longer considered secure, and are no longer allowed by SecureVideo's website.

TLS 1.0 is an encryption protocol used by web browsers that was released in 1996, and TLS 1.1 was released in 2006.

Newer, stronger protocols have been released since then; TLS 1.2 in 2008, and TLS 1.3 in 2018. Support for TLS 1.0 and 1.1 been retired already in the year 2020 by the major browsers (Chrome, Edge, Firefox, Safari, and Internet Explorer 11).

SecureVideo had continued support for these older protocols in deference to organizations that might be required to use older browsers like Internet Explorer 10 or older, or participants that might be using devices like Android 4.4.4 (KitKat) or Mac OS X 10.7 (Lion) or older, but support was retired for these protocols on February 12, 2021. 

 

Resolution

If you think your organization or participant may be using an older browser, or are not sure, you or the participant can run the SSL/TLS browser checker from Qualys SSL Labs by clicking here.

A positive result will say: Your user agent has good protocol support. (Example below.)

Protocol Support: Your user agent has good protocol support

 

This article was last reviewed by our Support team on February 12, 2021.